Sunline RV Forum
Sunline User Photos

Go Back   Sunline Coach Owner's Club > Technical Forums > Repairs and Maintenance
Click Here to Login

Join Sunline Club Forums Today


Reply
 
Thread Tools Search this Thread Display Modes
Old 06-10-2009, 06:48 AM   #1
Junior Member
 
Join Date: Jul 2008
Posts: 9
SUN #654
fairlaniac
Newest development in refer, still not completely working

Iíve had some posts on my refrigerator woes in my Sunline. Itís a Dometic 2612, 2 way. At first I had no refrigerator operations, now I have some life wit ha few different turn of events but Iím still not completely fixed. I replaced my circuit board with a Dinosaur 711. I have cleaned all of the contacts. On the 120V side I still get no action at all. If I have the 120V plugged into my house, have the refrigerator set on ďAutoĒ and turn it on, Iíll hear a click eventually and most times the ďcheckĒ light comes on and pops the GFI breaker at my receptacle in the garage. I have checked the heating element by contacting the wires with my multimeter and Iíve gotten a 44.1 ohm reading. Iím not sure what that means but all I know is the refrigerator is not working on 120V.

A question I have, does the 120V use any propane at all? Occasionally (last night) when I turned on the refrigerator using 120V it sounded like the burner trying to light or some similar sound. Or does 120V just rely on the electric heating element?

Onto the propane 12V a few things happening here. I actually pulled the 120V plug since itís not working to default the refrigerator to 12V. I started off by manually lighting the heater as my igniter did not seem to work. After a few hours running in ďAutoĒ mode the ďcheckĒ light would come on most likely due to the igniter not being able to refire? So then I put the refrigerator in ďmanualĒ mode (constant run) and manually light the burner. It runs for 10-15 hours and somewhere along the line it goes out with the ďcheckĒ light illuminated. Iím not sure why it will run for hours and then shut off? The gas is full, the battery is brand new and itís plugged into the garage receptacle. No last night I was double checking a few things, re-cleaning contacts, etcÖ All of a sudden the igniter is now firing and it lights the burner but after 30 seconds or so it goes out. This is the newest development so Iím not sure why after ignition it goes out? Is that a thermocouple issue?

I know there is a lot going on here but Iím determined to fix this thing. Itís been a learning experience and Iím getting to the point where I almost understand the entire working of the refrigerator but obviously there is a bit more to learn. Maybe you can help?

Thanks,
Doug
__________________

__________________
Doug
1995 Sunline T-1950
2005 Ford F250 Super Duty V10/Auto
fairlaniac is offline   Reply With Quote
Old 06-10-2009, 06:29 PM   #2
Moderator
 
JohnB's Avatar
 
Join Date: Nov 2006
Location: Ohio
Posts: 10,165
SUN #89
JohnB is on a distinguished road
Hi Doug

See comments in blue

Quote:
Originally Posted by fairlaniac
Iíve had some posts on my refrigerator woes in my Sunline. Itís a Dometic 2612, 2 way. At first I had no refrigerator operations, now I have some life wit ha few different turn of events but Iím still not completely fixed. I replaced my circuit board with a Dinosaur 711. I have cleaned all of the contacts. On the 120V side I still get no action at all. If I have the 120V plugged into my house, have the refrigerator set on ďAutoĒ and turn it on, Iíll hear a click eventually and most times the ďcheckĒ light comes on and pops the GFI breaker at my receptacle in the garage. I have checked the heating element by contacting the wires with my multimeter and Iíve gotten a 44.1 ohm reading. Iím not sure what that means but all I know is the refrigerator is not working on 120V.
44 ohms if OK on the AC element. The spec sheet calls for 40 ohms +- 10% so 44 is within tolerance. http://bryantrv.com/docs2/docs/reeftec.pdf See this site for tech manuals. http://bryantrv.com/docs.html

The breaker poping, did you do the short to ground check I typed you in the last note?



A question I have, does the 120V use any propane at all? Occasionally (last night) when I turned on the refrigerator using 120V it sounded like the burner trying to light or some similar sound. Or does 120V just rely on the electric heating element? The 120Volt system is separate from the LP. The 2 do not work at the same time on a fridge. If the burner was trying to actually light while on electric, something not right. Here is the install instructions on the RM2612 it talks about the auto switching between LP and electric. It is one or the other http://bryantrv.com/docs2/docs/12seriesim.pdf

Onto the propane 12V a few things happening here. I actually pulled the 120V plug since itís not working to default the refrigerator to 12V. I started off by manually lighting the heater as my igniter did not seem to work. After a few hours running in ďAutoĒ mode the ďcheckĒ light would come on most likely due to the igniter not being able to refire? So then I put the refrigerator in ďmanualĒ mode (constant run) and manually light the burner. It runs for 10-15 hours and somewhere along the line it goes out with the ďcheckĒ light illuminated. Iím not sure why it will run for hours and then shut off? The gas is full, the battery is brand new and itís plugged into the garage receptacle. No last night I was double checking a few things, re-cleaning contacts, etcÖ All of a sudden the igniter is now firing and it lights the burner but after 30 seconds or so it goes out. This is the newest development so Iím not sure why after ignition it goes out? Is that a thermocouple issue?

I know there is a lot going on here but Iím determined to fix this thing. Itís been a learning experience and Iím getting to the point where I almost understand the entire working of the refrigerator but obviously there is a bit more to learn. Maybe you can help?

Thanks,
Doug
My truck is done at the tire shop. Be back later
__________________

__________________
Current Sunlines: 2004 T310SR, 2004 T1950, 2004 T2475, 2007 T2499, 2004 T317SR
Prior Sunlines: 2004 T2499 - Fern Blue
2005 Ford F350 Lariat, 6.8L V10 W/ 4.10 rear axle, CC, Short Bed, SRW. Reese HP trunnion bar hitch W/ HP DC

Google Custom Search For Sunline Owners Club
JohnB is offline   Reply With Quote
Old 06-11-2009, 11:44 AM   #3
Junior Member
 
Join Date: Jul 2008
Posts: 9
SUN #654
fairlaniac
JohnB,
Thanks for the responses to this and the other post.

I think I'll be using a cooler for this weekends camping trip. I was just trying to get the gas side of the refigerator working and then deal with the 120V. Since it seemed like the igniter was working the other day I thought I'd try one last ditch effort before giving and using coolers. I bought a new thermocouple and installed it. Now I'm a few steps back again. Now the igniter does not ignite, I can manually light the heater but once again over night it went out and the "check" light was on. It had been running for 8 hours before I went to bed last night around 10:30. 6AM today it was out? I'm not sure why it stays lit for hours and goes out? I put the old thermocouple in before I headed to work today and the refrige did not ignite, but I could manually light it. I then went to work. I called the wife at lunch ans she checked it and it's still lit (6 hours so far).

So it seems as though my ignition is not working properly and something makes it shutdown after numerous hours of operation while in the manual mode?

Very frustrating, maybe I should have concentrated on the 120V side first?

Thanks,
__________________
Doug
1995 Sunline T-1950
2005 Ford F250 Super Duty V10/Auto
fairlaniac is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Am I posting, IS it working kanyonkitty Sunline Community 2 03-17-2010 04:32 PM
Kitty's newest mod!! EMD_Driver Sunline Community 10 12-12-2009 09:25 PM
Possible victim of Refer recall Sunline Fan Sunline Community 15 01-22-2009 04:18 PM
Interesting fuel development Mark Sunline Community 4 05-27-2008 09:29 PM
Newest member! tinybluetj Sunline Community 7 05-21-2008 08:49 PM


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Sunline RV or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:40 AM.


×