Sunline RV Forum
Sunline User Photos

Go Back   Sunline Coach Owner's Club > Sunline Club Community Forums > Sunline Community
Click Here to Login


Join Sunline Club Forums Today


Reply
 
Thread Tools Search this Thread Display Modes
Old 09-01-2014, 02:46 PM   #1
Junior Member
 
Join Date: Aug 2014
Location: Washington
Posts: 10
SUN #6653
Draagro is an unknown quantity at this point
Water heater problem. Thoughts?

I am having a water heater issue. It sparks up just fine. The flame seems to be burning strong. I do have enough LP in the tanks, but after about a minute or two It clicks off. Not just taper off I can hear the click of the system turning off. I replaced the two little thermostats hoping that was the quick fix, but no luck. The next two items to replace are the spark ignitor and/or the control panel.

any thoughts on this?
__________________

__________________
Draagro is offline   Reply With Quote
Old 09-01-2014, 03:05 PM   #2
Senior Member
 
Relie's Avatar
 
Join Date: Jul 2014
Location: Massachusetts
Posts: 267
SUN #6579
Relie is an unknown quantity at this point
Water heater

I had the very same symptoms on mine. It ended up being the sensor (of course, that's the expensive one, about $200 installed). Good luck with yours.

Dave
__________________

__________________
Relie is offline   Reply With Quote
Old 09-01-2014, 03:32 PM   #3
Senior Member
 
Join Date: Apr 2011
Location: Maine
Posts: 2,821
SUN #2097
mainah is an unknown quantity at this point
Quote:
Originally Posted by Draagro View Post
I am having a water heater issue. It sparks up just fine. The flame seems to be burning strong. I do have enough LP in the tanks, but after about a minute or two It clicks off. Not just taper off I can hear the click of the system turning off. I replaced the two little thermostats hoping that was the quick fix, but no luck. The next two items to replace are the spark ignitor and/or the control panel.

any thoughts on this?
A model number?
__________________
mainah is offline   Reply With Quote
Old 09-01-2014, 03:50 PM   #4
Junior Member
 
Join Date: Aug 2014
Location: Washington
Posts: 10
SUN #6653
Draagro is an unknown quantity at this point
you mean the spark and flame sensor? That sounds like a lot of money for the simple job!!

Quote:
Originally Posted by Relie View Post
I had the very same symptoms on mine. It ended up being the sensor (of course, that's the expensive one, about $200 installed). Good luck with yours.

Dave
__________________
Draagro is offline   Reply With Quote
Old 09-01-2014, 03:52 PM   #5
Junior Member
 
Join Date: Aug 2014
Location: Washington
Posts: 10
SUN #6653
Draagro is an unknown quantity at this point
It's an Atwood GC6AA-9E


Quote:
Originally Posted by mainah View Post
A model number?
__________________
Draagro is offline   Reply With Quote
Old 09-01-2014, 05:52 PM   #6
Senior Member
 
Relie's Avatar
 
Join Date: Jul 2014
Location: Massachusetts
Posts: 267
SUN #6579
Relie is an unknown quantity at this point
Water heater

Quote:
Originally Posted by Draagro View Post
you mean the spark and flame sensor? That sounds like a lot of money for the simple job!!
No, no. It was the control panel. Atwood heater, the controller top right.

Dave
__________________
Relie is offline   Reply With Quote
Old 09-01-2014, 07:53 PM   #7
Senior Member
 
Gene's Avatar
 
Join Date: Jan 2009
Location: Rhode Island
Posts: 1,515
SUN #768
Gene is an unknown quantity at this point
The flame sensor and/or wiring would be my first guess. Make sure the position is good and all electrical connections are good.
__________________

Gene & DW Ginny
2002 Sunline T-2363
2008 Toyota 4-runner 4wd 4.7L V-8
Reese Dual Cam straightline - P3 Brake controller
Gene is offline   Reply With Quote
Old 09-01-2014, 09:22 PM   #8
Moderator
 
JohnB's Avatar
 
Join Date: Nov 2006
Location: Ohio
Posts: 9,650
SUN #89
JohnB is on a distinguished road
Quote:
Originally Posted by Gene View Post
The flame sensor and/or wiring would be my first guess. Make sure the position is good and all electrical connections are good.
Does your look like this? The model number seemed to point it was this new. Is yours a late 2003 or 2004 and newer?


I agree with Gene on the connectors. There is a small thermal cut off saftey that is natouris for not making the connection. It is inside a clear piece of tubing in series with T stat. If may be possible the heat or vibration of the gas burning is shifting it enough to break the circuit and that will shut down the burner and "not" throw a fault light.

Unplug, clean them up and put some dielectric grease on them. The Auto parts stores has it. Also clean up the PC board connector.

Yours is a newer model (rev 9 pc board) so you also have an electric element, does it work on electric? Also on the newer ones like yours, the T stat and the thermal cut off also work on electric.

I would say at this point it is not the flame sense system. If the flame sense did not work right then it should be throwing a fault light, at least along one line of thinking anyway. The fault light is only for the gas mode.

Since your heater fired right off, the control board is working enough to create the entire firing sequence, which is quite a bit of working. The igniter is also working and it "sounded" like you state it stopped sparking once it lit. Did it? If so then the flame sense is working as that is what shuts down the ingiter.

This seems to point to loosing the T stat and thermal cut off saftey circuit. If that path does not make, it shuts the whole thing down and will not throw a fault light.

If you go here and zoom all the way to the bottom, there is a 2004 Atwood service manual. Page 25 has the wiring diagram of the heater. Same one as the little diagram sticker on the heater under the control board. Service Documents and Manuals

Hope this helps

John
__________________

__________________
Current Sunlines: 2004 T310SR - Fern Blue, 2004 T1950 - Fern Blue, 2004 T2475 - Nutmeg
Prior Sunlines: 2004 T2499 - Fern Blue
2005 Ford F350 Lariat, 6.8L V10 W/ 4.10 rear axle, CC, Short Bed, SRW. Reese HP trunnion bar hitch W/ HP DC

Google Custom Search For Sunline Owners Club
JohnB is offline   Reply With Quote
Reply

Tags
water heater


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Saturn T-2161 remodeling thoughts. Help us think it through please. Erin Modifications 5 03-29-2013 05:36 AM
thoughts on trailer covers please wayne singer Sunline Community 4 07-22-2012 07:08 AM
Leak in 2006 1950 near couch--any thoughts??? Nancy G. Repairs and Maintenance 5 04-19-2011 12:26 PM
TT Accident, Thoughts on Toy Haulers MACK C-85 Towing and Tow Vehicles 5 10-05-2009 05:19 PM
Modification thoughts - comments? precorguy Modifications 7 11-11-2007 06:30 PM



Disclaimer:

This website is not affiliated with or endorsed by Sunline RV or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:54 PM.