Sunline RV Forum
Sunline User Photos

Go Back   Sunline Coach Owner's Club > Model Specific Forums > Sunline Travel Trailers
Click Here to Login

Join Sunline Club Forums Today


Reply
 
Thread Tools Search this Thread Display Modes
Old 09-24-2011, 03:36 PM   #1
Junior Member
 
Join Date: Jul 2011
Location: Pennsylvania
Posts: 11
SUN #2530
PotterBound is an unknown quantity at this point
water heater not lighting

I am having trouble lighting my water heater in my 86' Satallite. I can get the pilot light to take, but when I switch over to the "on" position to ignite.... it back flashes and catches on fire at the flame adjustment part. Could this be simply spider webs or bees nest in the ignition tube? Or is it in need of adjustment? I am fairly new to trouble shooting an LP water heater.

Thanks in advance!
Aaron
__________________

__________________
Tow vehicle - '97 Ford, F350, CC, 7.3psd, zf5, 4x4, DIY cold air, 4" sus. lift, 4" exhaust, 285k and ticking, and occasionally run my Edge Evolution programmer

In tow - 1986 Sunline Satillite 19', in almost mint condition
PotterBound is offline   Reply With Quote
Old 09-24-2011, 05:42 PM   #2
Senior Member
 
Gene's Avatar
 
Join Date: Jan 2009
Location: Rhode Island
Posts: 1,515
SUN #768
Gene is an unknown quantity at this point
That sure sounds like something built a nest somewhere along the flame path. The easiest place to look first is the burner tube then the flame tube through the water heater itself. A blast of air from a compressor may help and then a long flexible bottle brush through the flame tube.
__________________

__________________

Gene & DW Ginny
2002 Sunline T-2363
2008 Toyota 4-runner 4wd 4.7L V-8
Reese Dual Cam straightline - P3 Brake controller
Gene is offline   Reply With Quote
Old 09-24-2011, 08:05 PM   #3
Junior Member
 
Join Date: Jul 2011
Location: Pennsylvania
Posts: 11
SUN #2530
PotterBound is an unknown quantity at this point
Quote:
Originally Posted by Gene View Post
That sure sounds like something built a nest somewhere along the flame path. The easiest place to look first is the burner tube then the flame tube through the water heater itself. A blast of air from a compressor may help and then a long flexible bottle brush through the flame tube.
Thanks I will try that out! I actually found that the pilot light feed line was cracked at the fitting closest to the pilot area, so I will have to get a replacement for that first, and fingers crossed that it is what was causing the back flash. But if not I will go about checking there. The heating unit had some wasp nests and other stuff, so it wouldn't surprise me at all.
__________________
Tow vehicle - '97 Ford, F350, CC, 7.3psd, zf5, 4x4, DIY cold air, 4" sus. lift, 4" exhaust, 285k and ticking, and occasionally run my Edge Evolution programmer

In tow - 1986 Sunline Satillite 19', in almost mint condition
PotterBound is offline   Reply With Quote
Old 09-25-2011, 03:30 PM   #4
Senior Member
 
Gene's Avatar
 
Join Date: Jan 2009
Location: Rhode Island
Posts: 1,515
SUN #768
Gene is an unknown quantity at this point
Yes, the crack in the feed line is probably the main suspect so, as you said, that would be first on the list.

Let us know how you make out.

Gene
__________________

Gene & DW Ginny
2002 Sunline T-2363
2008 Toyota 4-runner 4wd 4.7L V-8
Reese Dual Cam straightline - P3 Brake controller
Gene is offline   Reply With Quote
Old 09-25-2011, 05:17 PM   #5
Junior Member
 
Join Date: Sep 2011
Location: Virginia
Posts: 21
SUN #2821
bodatiouskid is an unknown quantity at this point
I have a 1995 T2251 doing the same thing.You light it & flame backfires through the adjustment tube & black smoke comes out of exhaust.
__________________
bodatiouskid is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What did the PO do to our water heater? EMD_Driver Repairs and Maintenance 14 09-21-2009 09:04 AM
Water Heater 264SRinPA Repairs and Maintenance 8 06-18-2009 07:22 AM
1992 T-2053 Water lines from water heater sfven Repairs and Maintenance 1 03-06-2009 03:22 PM
Atwood water heater water hose connections problems Sunline1 Repairs and Maintenance 17 08-31-2008 01:01 PM
Leaky City Water Intake or Water Heater? sunlineclub Repairs and Maintenance 4 06-09-2008 07:24 PM



Disclaimer:

This website is not affiliated with or endorsed by Sunline RV or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:41 AM.