Sunline RV Forum
Sunline User Photos

Go Back   Sunline Coach Owner's Club > Model Specific Forums > Sunline Travel Trailers
Click Here to Login

Join Sunline Club Forums Today


Reply
 
Thread Tools Search this Thread Display Modes
Old 11-11-2012, 07:24 PM   #1
Member
 
MarknShana's Avatar
 
Join Date: Jan 2010
Posts: 48
SUN #988
MarknShana
Question TV Antenna & Radio problems

Our television antenna has stopped picking up channels. It used to pick up several channels now it won't pick up ANYTHING, even when the booster is on and about the same time that happened our radio stopped working. The buttons light up but when you press them nothing happens . Any ideas? Thanks in advance for ANY help/suggestions!!
__________________

__________________
The Ellis Family
ALABAMA
2005 Sunline Solaris T-2363
2004 F-150 Lariat Crew Cab 4x4
MarknShana is offline   Reply With Quote
Old 11-11-2012, 08:01 PM   #2
Member
 
Join Date: Jul 2011
Location: Pennsylvania
Posts: 54
SUN #2485
aaron is an unknown quantity at this point
I’m going to take a shot in the dark and say an F-connector has pulled out somewhere. Do you have TV while connected to park cable? If you do have park cable, trace out the line to the antenna. I believe there is a connection just inside the ceiling near the crank for the antenna. Might want check that and there is also connection on the roof to the head of the antenna. Check all connections and ensure the cable is not ‘sucking out’ of the F-connector. The white dialectic should be flush with the bottom threaded part. Poor connections are the biggest reason for TV issues. Most manufactures do a horrible job at this; however Sunline did nearly a perfect job. I replaced all my connections on all my other trailers, except the Sunny.
__________________

__________________

Aaron
2006 T-2553
2009 GMC Sierra 1500 3.73 6-speed
aaron is offline   Reply With Quote
Old 11-11-2012, 08:25 PM   #3
Moderator
 
JohnB's Avatar
 
Join Date: Nov 2006
Location: Ohio
Posts: 10,511
SUN #89
JohnB is on a distinguished road
If this is the roof antenna, then there is a possibility it may be the amplifier up on the roof antenna. In the 2004 time frame Wineguard had some issues where the roof unit would die. Your 2005 camper may have a 2004 build date and be unlucky like me….

Before I would change the roof unit, check the connections. You can unscrew and pull out the wall amplifier and see them behind that area.

In my case I checked all the connections I could get to. Nope, not that. Then changed the wall amplifier, nope not that. There is not much left after that other than the wire going up to the roof and the roof amplifier. So I bought a 25 foot cable from Lowes, screwed it in the back side of the wall amplifier where the roof unit hooks in, ran the cord outside the camper and up to the roof unit direct. Nothing….

Bought a new Wineguard bat wing head and it works great. And I have lots of spare parts now…

We are assuming the little green light is turning on the wall amplifier, yes/no? If the answer is yes, then it points to something in the roof signal not getting to the TV set. If the answer is no, then you need to track down why it is not getting power. About the only connection I can think of between the radio and the TV antenna is the power source may be on the same fused line. Other than the power feed, I cannot see how the TV antenna interacts with the radio.

Hope this helps and let us know how you make out.

John
__________________
Current Sunlines: 2004 T310SR, 2004 T1950, 2004 T2475, 2007 T2499, 2004 T317SR
Prior Sunlines: 2004 T2499 - Fern Blue
2005 Ford F350 Lariat, 6.8L V10 W/ 4.10 rear axle, CC, Short Bed, SRW. Reese HP trunnion bar hitch W/ HP DC

Google Custom Search For Sunline Owners Club
JohnB is offline   Reply With Quote
Old 11-11-2012, 08:32 PM   #4
Moderator
 
JohnB's Avatar
 
Join Date: Nov 2006
Location: Ohio
Posts: 10,511
SUN #89
JohnB is on a distinguished road
Quote:
Originally Posted by MarknShana View Post

and about the same time that happened our radio stopped working. The buttons light up but when you press them nothing happens . Any ideas? Thanks in advance for ANY help/suggestions!!


H'mm OK I missed the buttons lighting up part. If the radio lights come on but no sound comes out, then you are getting power to the radio.

I would unscrew the 4 screws holding it in and check the monster wire harness behind it for a loose connection. Your speakers may of become disconnected.

Describe, nothing happens. Can you see the station channel in the display? Or is it just no sound coming out?
__________________
Current Sunlines: 2004 T310SR, 2004 T1950, 2004 T2475, 2007 T2499, 2004 T317SR
Prior Sunlines: 2004 T2499 - Fern Blue
2005 Ford F350 Lariat, 6.8L V10 W/ 4.10 rear axle, CC, Short Bed, SRW. Reese HP trunnion bar hitch W/ HP DC

Google Custom Search For Sunline Owners Club
JohnB is offline   Reply With Quote
Old 11-12-2012, 05:30 AM   #5
Senior Member
 
Join Date: Apr 2011
Location: Maine
Posts: 3,083
SUN #2097
mainah is an unknown quantity at this point
The amp is in side of the antenna on the roof what you'll need to do is check it with a volt meter. Turn the switch on disconnect the connection at the antenna and check for voltage between the little wire in the center of the connector and the outside ring on the cable. It should be some thing close to 12 volts if it has 12 volts to amp in the antenna is toes up and you'll need a new antenna head. As far as the radio that sounds internal. You all didn't have a very close thunderstorm did you?
__________________
mainah is offline   Reply With Quote
Old 11-12-2012, 10:22 AM   #6
Member
 
MarknShana's Avatar
 
Join Date: Jan 2010
Posts: 48
SUN #988
MarknShana
Quote:
Originally Posted by JohnB View Post
Describe, nothing happens. Can you see the station channel in the display? Or is it just no sound coming out?
No, you cannot see the channel display, it is lit up but no numbers are displayed, just blank. All of the button lights light up. When you press the power button to turn them off, nothing happens. The buttons remain lit all of the time, as long as the camper is plugged into electricity.

Thanks for your help!
__________________
The Ellis Family
ALABAMA
2005 Sunline Solaris T-2363
2004 F-150 Lariat Crew Cab 4x4
MarknShana is offline   Reply With Quote
Old 11-15-2012, 10:10 AM   #7
Senior Member
 
OhhWell's Avatar
 
Join Date: Feb 2011
Location: Florida
Posts: 213
SUN #1879
OhhWell is an unknown quantity at this point
Almost sounds like you took a lightning hit to the antena or something. Just for the heck of it though, try unplugging the camper and disconnecting the battery for 20 min or so.
__________________

__________________
Current RV - 1999 Bounder 36s

Former trailers - '94 T-2770
'02 t-2753
'08 Keystone Sprinter 299BHSS
OhhWell is offline   Reply With Quote
Reply

Tags
antenna, cd player, radio, television


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Эроти& chuckieg Sunline Travel Trailers 1 05-28-2009 07:57 PM
Radio problems Janalee Repairs and Maintenance 1 01-20-2008 02:19 PM
Radio Antenna JohnIL Sunline Travel Trailers 5 11-24-2007 11:38 AM


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Sunline RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 02:06 AM.


×