Sunline RV Forum
Sunline User Photos

Go Back   Sunline Coach Owner's Club > Technical Forums > Repairs and Maintenance
Click Here to Login

Join Sunline Club Forums Today


Reply
 
Thread Tools Search this Thread Display Modes
Old 03-20-2010, 02:09 PM   #1
Member
 
Join Date: Mar 2009
Posts: 40
SUN #811
dryflie
Onan Generator issue

So this is not exactly a camper problem but the Genset is connected to it so it might qualify. Bought a used Sunline last year with a Genset on the back end. Got it all wired correctly and it starts and runs but only if I hold down the start button (either at the generator or the inside remote start). It will run just fine as long as that start button is depressed but once my finger is removed it dies. It's getting gas, oil is brand new, as I said it will run fine for minutes with the start button depressed. The cover is on so if was a safety interlock that's not the issue.

Any clever ideas?

Thanks
Al
__________________

__________________
dryflie is offline   Reply With Quote
Old 03-20-2010, 09:50 PM   #2
Moderator
 
EMD_Driver's Avatar
 
Join Date: Jul 2009
Location: West Virginia
Posts: 2,039
SUN #897
EMD_Driver is an unknown quantity at this point
Send a message via MSN to EMD_Driver Send a message via Yahoo to EMD_Driver
Hi Al,


What type of gas, does the genny run on? Gasoline, or LP gas?


Gary
__________________

__________________
Gary
SunlineClub Custom Google Search

2007 Peterson Excel Limited 30RKE
2014 Ford F350XLT SRW Crew Cab, Long bed 6.7PSD

EMD_Driver is offline   Reply With Quote
Old 03-20-2010, 09:55 PM   #3
Moderator
 
JohnB's Avatar
 
Join Date: Nov 2006
Location: Ohio
Posts: 10,162
SUN #89
JohnB is on a distinguished road
Hi Al

We are A ok asking for help fixing anything connected with camping or a Sunline, so a Gen set for sure qualifies.

While I don not know your exact Gen set, I use to have a small engines repair business a long time ago so there are only some many things that can cause what you are describing.

If it runs great with you holding the button and dies when you release it, it points to the switch or something some how killing the ignition.

Do you know if this unit has a magneto or a coil for the spark ignition? If it has a magneto something is grounding out the run signal as that is how you stop them. If it is a coil that runs off a battery used for electric start, then the power to the coil if dropping out.

Do you have a volt meter? And are motor electric friendly?

And what about an Onan Model/serial number. I can look up and see if they have a cut sheet on exactly what you have so I can see what you are up against and better point where to go look.

I know Kitty and EMD_Driver have and Onan genset but do not know models etc.

Glad to help as I can

John

As a last resort some pics with showing the system electrical so I can figure out what you have.
__________________
Current Sunlines: 2004 T310SR, 2004 T1950, 2004 T2475, 2007 T2499, 2004 T317SR
Prior Sunlines: 2004 T2499 - Fern Blue
2005 Ford F350 Lariat, 6.8L V10 W/ 4.10 rear axle, CC, Short Bed, SRW. Reese HP trunnion bar hitch W/ HP DC

Google Custom Search For Sunline Owners Club
JohnB is offline   Reply With Quote
Old 03-20-2010, 10:10 PM   #4
Moderator Emeritus
 
kanyonkitty's Avatar
 
Join Date: Aug 2006
Location: West Virginia
Posts: 2,289
SUN #17
kanyonkitty is an unknown quantity at this point
Our Genny is an Onan 3600LP (propane) if that will help, I can get the manuals out, (but NOT tonight).

Kitty
__________________
Sunny #18 2003 F-344SR #8157
Sunny #19 1997 T-2653 #5485
1999 Ford F350XLT DRW Crew Cab, Long bed 7.3 PSD
2002 VW Jetta TDI.. AKA: Kitty's Kruiser
kanyonkitty is offline   Reply With Quote
Old 03-22-2010, 08:48 AM   #5
Member
 
Join Date: Mar 2009
Posts: 40
SUN #811
dryflie
Thanks for the replies. A bit of research on my part has turned up some answers. Turns out that this problem is very very common for generators that have been inactive for long times. There are three possible reasons for the problem.

1. The generator isn't producing any AC output. This would point to a wiring problem perhaps. The control board prevents the engine from continuing to run.

2. A bad regulator does the same thing.

3. Most common cause of all is a stuck LOP (low oil Pressure) switch. Inactivity make this switch stick and once again the control board prevents the engine running to avoid damage.

So I've got to get the trailer to an RV shop with Onan experience and hope they can pin the problem down. Good thing is that the generator does run fine with the start switch depressed so hopefully once the problem is determined and corrected we'll be making power.
__________________
dryflie is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP with another 'lectrical issue Wgeorgell Repairs and Maintenance 1 10-05-2009 08:05 PM
Electrical Code issue Galaxiedriver Repairs and Maintenance 1 09-07-2009 04:25 PM
Air Conditioner Issue janetpowell Repairs and Maintenance 5 08-27-2009 03:47 PM
Generator Both2Retired Sunline Community 5 01-05-2009 08:02 AM
Electrical Issue? chuck & lori Repairs and Maintenance 5 07-03-2008 11:31 AM


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Sunline RV or any of its affiliates. This is an independent, unofficial site.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:41 PM.


×